SYSE Kundeservice

Hei! Hva kan vi hjelpe deg med?

Finne avvik og skadelig kode i Wordpress filer (core)

Følg

wp-diff er et verktøy utviklet av SYSE, og sammenlikner core-filer som tilhører WordPress med filer på webhotell eller TWS-kontoer for å identifisere skadelig kode. Scriptet sjekker WordPress-versjon som kjører på din konto og kjører en md5 checksum sammenlikning mellom originale filer og filer på kontoen for å finne filer som er:

  • lagt til eller
  • modifisert

Scriptet tar ikke høyde for innhold i wp-content som ikke er core-filer.

Resultatet av dette søket brukes til å identifisere filer som er endret og lagt til i din WordPress installasjon. Som oftest inneholder disse filene skadelig kode og bør fjernes umiddelbart. 

Scriptet kjøres fra kommandolinjen på din konto:

/usr/local/sbin/wp-diff

NB! Dersom versjonen av WordPress som er i bruk ikke er lastet ned til vårt versjonslager vil jobben feile. Kontakt med Kundeservice med feilmeldingen som oppstår, og oppgi hvilken konto du forsøker å kjøre jobben på. Feilmeldingen ser slik ut: 

Cache for version 4.7.12 not found, must run as root, aborting...

NB ! Denne funksjonen vil også liste ut alle filer du selv har lagt inn på din WordPress installasjon. Filer du kjenner innholdet i, og stoler på, gjør du selvfølgelig ingenting med. 

 

Var denne artikkelen nyttig?
0 av 0 syntes dette var nyttig

Kommentarer